Platform Help Center

How to install/upgrade Java


With the next upgrade in Minecraft and Minecraft mods progressing into 1.7.2, more and more mods are dropping support for Java 6.
 
Before upgrading Java make sure your computer supports it by checking here: http://java.com/en/download/help/sysreq.xml
 
Unlike Windows and Mac, major Linux distributions such as Ubuntu, Fedora or Red Hat Enterprise Linux offer OpenJDK as their default Java SE implementation.
 
32-bit vs 64-bit and what does it mean?
 
Long story short, you cannot run a computer with more memory than 4GB if you use 32-bit.
 
Technic recommends using 64-bit versions of Java (if supported). This allows more memory for Minecraft to use. 
 
Questions or how to check your system can be found here:
 
Windows users: http://windows.microsoft.com/en-us/windows/32-bit-and-64-bit-windows
 
Mac users: http://support.apple.com/en-us/HT201948
 
Linux users: http://stackoverflow.com/a/246014
 
If you are needing to upgrade your Java install, grab a copy from here and follow these guides: http://java.com/en/download/manual.jsp
 
Windows Users:
 
Check what version of Java your running by going here: http://java.com/en/download/uninstallapplet.jsp
 
Or checking your installed programs by going to: Control Panel -> Programs and Features
 
and following this guide: http://java.com/en/download/help/windows_offline_download.xml
 
 
Mac Users:
 
You have special requirements for installing/uninstalling Java on your computers
 
Please read CLOSELY here: http://java.com/en/download/faq/java_mac.xml

 

If you cannot uninstall Java 6, install Java 7 and then follow thses steps:

 

  • Next start the Java Preferences app from /Applications/Utilities
  • Drag Java 7 to the top of the list like in the screenshot. This will make locally run Java applications use Java 7 instead of Java 6.
  • You can uncheck the Java 6 options if you do not want them to be allowed to run.
  • This section is for the Java runtime for local applications, and has nothing to do with the web plugin.

 

 
 
Linux Users:
 
Ubuntu and Fedora users: http://openjdk.java.net/install/
 
Red Hat, SUSE, Oracle, Oracle Enterprise, SLES users: http://java.com/en/download/help/linux_install.xml

 

Final Step:
 
After you have installed Java 7, check to make sure it is installed here: http://java.com/en/download/installed.jsp
 
Hope this helps clear things up!

 

Have more questions? Submit a request

Comments

  • Avatar
    aaronbray91

    I have Java 8 installed. But the launcher only lets me select java 6. what gives? I'm on a Mac btw

  • Avatar
    IceWizzard

    I have this same problem

  • Avatar
    thecraftable44

    same. on a mac as well. because of this i can hardly play any good mod packs

  • Avatar
    sandertje100

    Same problem, I have java 8 and the launcher let me only select java 6, now in can't play most of the modpacks...
    What do I need to do?

  • Avatar
    sandythorne

    if u go to the java website and download 64bit java it fixes it all :}

  • Avatar
    sandertje100

    I already have Java 8 64bit...
    I'm on a Mac btw

  • Avatar
    nazizombiesrock

    are they going to fix the problem already i have been looking up every thing to fix this problem but still cant find a way to fix it they should really do something about it for us mac users we cant play new 1.7.10 packs because of this stupid problem with java

  • Avatar
    nazizombiesrock

    if one of u guys find a solution to this problem keep me updated in this chat they will probably post something on tweeter about this

  • Avatar
    nazizombiesrock

    there only seems to be java 6 on the java setting on the mac launcher and i have installed java eight and on my mac i can not install java 7 because mac has disabled being able to install java 7. and java 8 or 7 are the only things i need to be able to play 1.7.10 mod packs on the launcher. i am not a idiot java is in version 8 because i am able to play 1.8 and single mods in 1.7.10. and i looked up every thing to fix this problem i checked the help center (how to install/upgrade java) and people in the comments had the same issue as me and people have possed it on the same day this happened to me. i dont now what to do how to put java 8 and remove java 6 i dont think this is just my problem as well as other mac users are experiencing the same issue it was not in the help center so if there is a way to fix this please respond. i do not know if this is a bug but it might be.

  • Avatar
    sandertje100

    I submitted a question about this and this was the reply:

    Hey there, thank you for the detailed support request. Have you tried to install the Java 8 JDK instead of the the regular Java 8? This is a bit more essential for Mac users. You can find the JDK installs here: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

    This is the help page:
    https://technicpack.zendesk.com/hc/en-us/requests/203

    I tried it..
    And it worked!!

  • Avatar
    Alexander14creator

    This happens to all of my mod packs I try to download: Error downloading a file for the following pack: Mianite Season 2 [MS2]. Failed to download http://files.minecraftforge.net/maven/org/scala-lang/scala-xml_2.11/1.0.2/scala-xml_2.11-1.0.2.jar PLEASE CONSULT THE MODPACK AUTHOR.

  • Avatar
    PaisleyP

    @sandertje100
    Worked for me too, thanks for posting the solution for all us Mac Java 8 users!

  • Avatar
    NetherDeader

    Im a Mac user and cant update my java to 1.8 from 1.6 since there isnt a folder called Java Preferences.

  • Avatar
    paradox516

    Tekkit pls help me when i play tekkit and i build something and idk why the game kick me out from the srw (signleplayer) and i cant play myltiplayer pls help me :/ !!!!

  • Avatar
    Sniper17

    I keep getting this

    Stack Trace:
    Exception: IndexOutOfBoundsException
    Message: Index: 0, Size: 0
    Trace:
    java.util.ArrayList.rangeCheck (Unknown Source)
    java.util.ArrayList.get (Unknown Source)
    org.spoutcraft.launcher.skin.NewsComponent.setupArticles(News Component.java:60)
    org.spoutcraft.launcher.skin.NewsComponent.loadArticles(NewsComponent,java:46)
    org.spoutcraft.launcher.Launcher$2.run(Launcher.java:105)

    How do I fix this issue??

  • Avatar
    Bob_I_Am

    By the way, I've found (On Windows 8) that Java 8 doesn't work with some modpacks. So if you are running Java 8, I recommend getting Java 7 as well: http://www.java.com/en/download/manual_java7.jsp

  • Avatar
    TheShambler001

    I have followed the instructions on both mac and windows 8.1 and it hasnt worked at all on either the modpack Lay of the land just crashes immediately.
    Ive had the same issue with other packs so im starting to think its a problem in the technic launcher rather than the mod creators.

  • Avatar
    grub_25

    I'm using windows 7 (64 bit). I have everything it says i should need but its still not working. I click play and it starts to look like its working then it gets to initialising and it stops and says not responding. So i found that you need to go to the settings and give it more RAM but mine only gives me the option for 512mb, 768mb, or 1gb. So i found that i need 64 bit java to be able to increase it more but as far as i can tell i have that. I have java 8 64 bit. I dont know what to do because everywhere else it says you need to upgrade to a 64 bit version of java but i have that. help

  • Avatar
    Gaming_Zer0

    it doesn't work I'm on mac and I'm using Java 7 still it only gave me the Java 6 option

  • Avatar
    Dr Newph

    I have installed the most updated version of java and when i go to my launcher settings it wont let me select any memory past 1gb. I have uninstalled and reinstalled java 5 times and it is still not working. It is driving me crazy please help

  • Avatar
    EariosRandomness

    I'm using the latest version of Java, and I'm on a PC running Windows 8.1 (64-bit). For some reason, the launcher won't let me select anything above 1 GB RAM, and I want to run a modpack that requires 2 GB RAM. Any advice?

  • Avatar
    arist_soldier

    i'm running windows 7 with java 8 installed, everytime i try to open the pack i get a message saying "Java Runtime Enviroment is required" ive tried to figure out how to fix this but i am having no luck

  • Avatar
    altarialite

    I use windows 7 with java 8 64-bit, but every time i try to open main tekkit it gives me "java SE binary is not responding"
    it works with tekkit lite, however. am i just not using enough memory for it?

  • Avatar
    HydralordX

    I can't Go to Java 1.7 In The Technic Pack. it says "Click Here" But it Wont Work. Please Help!!

  • Avatar
    HydralordX

    Im on a Mac Btw

  • Avatar
    DoggiePlayzz

    The launcher inst a startup item......... can someone help me!!

  • Avatar
    Minecraft_cat2003

    I have the newest java Installed 64bit but for some stupid reasons it only lets me use java 32 I cant find 64 anywhere on the select version tab, so it only allows me 1gb? because of this im not allowed to play like any modpacks, I lag like crazy on a lot, I crash a lot because memory shortage, and I have to have a short render distance its stupid, and the clikc here to fix it button dosnt even work! im very disappointed -_-

Powered by Zendesk